Using MPLABX on Linux

I am using the Uno32 from ChipKit for a programming class, and I struggled to be able to program it from linux. Here are instructions to install the editor and set up a project for the board.

How to install MPLabX

  1. Download the MPLABX installer from http://microchip.com/pagehandler/en-us/family/mplabx/, then run it.
  2. Download the XC32 compiler from http://microchip.com/pagehandler/en-us/devtools/mplabxc/, then run it.

How to create a project

  1. File > New Project
  2. Choose Project: Microchip Embedded > Standalone Project
  3. Select Device: Family: 32-bit MCUs (PIC32), Device: PIC32MX320F128H
  4. Select Tool: Hardware Tools > Simulator
  5. Select Compiler: XC32 > XC32 (vX.XX) [$PATH]
  6. Check Set as main project
  7. After the project is created, go to File > Project Properties > Conf: [default] > Simulator > Uart1 IO Options and check the box labeled Enable Uart1 IO, then go to Uart2 IO Options and Enable Uart2 IO as well.